Sollten Sie warten, bis Angular 2.0 veröffentlicht wird, bevor Sie AngularJS lernen?

Angesichts der Tatsache, dass sich Angular 2.0 stark von der aktuellen 1.x unterscheiden wird, fragen sich einige Anfänger, ob es eine gute Idee wäre, Angular nach der Veröffentlichung von 2.0 zu lernen. Dieser Blogbeitrag hilft den Lesern zu verstehen, was sie tun sollten.

Die Textzusammenfassung wurde vom Codementor-Team verfasst und basiert auf den Codementor-Bürozeiten, die von Craig McKeachie veranstaltet werden, der die verfasst hat JavaScript-Framework-Leitfaden. Die Zusammenfassung kann vom Originalvideo abweichen, und wenn Sie Probleme sehen, teilen Sie uns dies bitte mit!


Youtube – Wählen Sie Ihre Religion

Es ist sinnvoll, Angular in seiner aktuellen Form jetzt zu lernen, da Sie die Apps jetzt erstellen müssen. Basierend auf dem, was das Google-Team bisher gesagt hat, wird Angular 2.0 erst Ende nächsten Jahres veröffentlicht, und das ist ein ganzes Jahr der Softwareentwicklung, das Sie verpassen würden, wenn Sie auf das nächstbeste Angebot warten. Darüber hinaus hat das Angular-Team gerade Version 1.3 veröffentlicht, es ist also nicht so, als würden Sie keine neuen Funktionen erhalten.

Es gibt Syntaxunterschiede neben anderen drastischen Änderungen, aber das Angular-Team wird wahrscheinlich die negativen Reaktionen anderer Leute berücksichtigen und 2.0 näher an das aktuelle Framework bringen. Sie wollen wahrscheinlich nicht die große Benutzerbasis und Community verlieren, die sie derzeit haben, also kann man von ihnen erwarten, dass sie einen Migrationspfad finden, der funktioniert. Sie können bereits sehen, dass sie in der jüngsten Kontroverse bei Ng-Europe ein paar Schritte zurückgetreten sind, und die beste Zusammenfassung davon finden Sie unter devchat.tvwo das gesamte Angular-Team über die Frage spricht, ob sie Abwärtskompatibilität unterstützen werden.

Außerdem mache ich viele Schulungen für wirklich große Banken, deren Namen ich nicht nennen kann, aber ich weiß, dass viele von ihnen ihre Apps von Java # auf Angular umstellen. Sie haben sogar IE-Probleme, also werden sie auf Angular 1.2 umsteigen, weil 1.3 die IE8-Unterstützung fallen lässt. Alles in allem denke ich, dass es deshalb immer noch eine riesige Community von Leuten geben wird, die AngularJS-Apps in der aktuellen Version erstellen.

Similar Posts

Leave a Reply

Your email address will not be published. Required fields are marked *